While installing Malwarebytes for Windows, you may encounter a runtime error message similar to the example below.
Runtime Error (at xx:xxx): Could not call proc.
If you are attempting to install on XP or Vista, see Malwarebytes support for Windows XP and Vista for more information.
Cause
Malwarebytes for Windows needs to be able to save files to the %TEMP% folder during installation. If the Malwarebytes for Windows setup file encounters Runtime Error: Could not call proc. during installation, this suggests the %TEMP% folder is either located on a network or Random Access Memory Drive, also known as a RAMDrive or RAMDisk.
Workaround
If Malwarebytes for Windows displays Runtime Error: Could not call proc. during installation, follow the steps below to install Malwarebytes for Windows.
- Download the latest version of Malwarebytes for Windows.
- Run Command Prompt as an Administrator.
- Click the Start menu icon or press the Windows key.
- To find Command Prompt, type cmd in the search box.
- Right-click Command Prompt, then click Run as Administrator.
- Click the Start menu icon or press the Windows key.
- When the black Command Prompt window opens, type the commands below into the window. Press Enter after each line.
set TEMP=C:\Windows\temp
set TMP=C:\Windows\tmp
cd "%USERPROFILE%\Downloads" - Type mb3-consumer-setup-x.x.x.xxxx, replacing x.x.x.xxxx with the setup file numbers downloaded in step 1.
- Press Enter to start the Malwarebytes for Windows Setup Wizard.
Choose your setup language, then follow the prompts to complete installation.
- Click Agree and Install.
To choose a different install location, click Advanced Options. - When installation is complete, click Finish.
If Malwarebytes for Windows notifies you an upgrade is available, we recommend installing the upgrade to receive the latest features, improvements, and fixes.