Version compatibility error message with Endpoint Protection and macOS

Document created by aprobert Employee on Jul 18, 2019Last modified by jgolomb on Jul 31, 2019
Version 9Show Document
  • View in full screen mode

This article provides information about Malwarebytes' support for macOS Mojave 10.14.5 update requirement for notarization of kernel extensions by Apple.

 

Applicability

Malwarebytes Endpoint Protection - real-time protection.
(Not required for Incident Response)

 

Operating systems

MacOS 10.14.5+

 

Possible Error Message and Popup

The following error message may occur which you may safely ignore, "System Extension Warning - One or more system extensions that you have approved will be incompatible with a future version of macOS".

 

This error occurs because Apple have introduced a new requirement for vendors to submit their kernel extensions to Apple for notarization. It does not occur if the endpoint software has been deployed using a Mobile Device Management (MDM) system such as JAMF or SimpleMDM. Malwarebytes developers have already notarized our kernel extension and deployed it into the Home Premium product. An update to Endpoint Protection is in progress in accordance with regular monthly release cycles.

 

Recommendations

Deploy Endpoint Protection using a Mobile Device Management system.  Refer to Issue deploying Endpoint Protection on macOS for more information. This also suppresses the requirement for an end user to accept the kernel extension itself.

 

References

https://developer.apple.com/documentation/security/notarizing_your_app_before_distribution

Attachments

    Outcomes