Malwarebytes Management Console TLS support

Document created by djacobson Employee on Dec 20, 2018Last modified by jyamada on Jan 23, 2019
Version 4Show Document
  • View in full screen mode

The Malwarebytes Management Console requires TLS 1.0 for initial installation. To successfully setup the Management Console, temporarily enable this protocol to perform the installation.

Configure TLS 1.1 and 1.2 after installation. Support for these configurations below.

 

Post-install TLS 1.1 and 1.2 configuration

Client deployment and install package creation

  • Edit file C:\Program Files (x86)\Malwarebytes Management Server\PackageTemplate\SCComm.xml 
    Look for the following line:
    <supportedRuntime version="v2.0.50727" />
    Change the version value to:
    <supportedRuntime version="v4.0.30319" />

 

.Net requirements for Management Console server and client's OS

Installs using TLS 1.1 and 1.2 require .NET 4.6 or a fully patched .NET 4.5 to be installed.

 

 

SQL connection setup

Default Embedded SQL Express

Malwarebytes Management Console comes bundled with SQL Express 2008 R2. In order to support TLS 1.1 and 1.2:

 

External SQL Full

Refer to the following Microsoft update information to support TLS 1.1 and 1.2 on the SQL Server and Server OS versions in use: https://support.microsoft.com/en-us/kb/3135244

 

 

Finalize Management Console installation

After installing updates/patches, disable TLS 1.0 on the server and reboot. Management Console should now function using TLS 1.1 and 1.2.

1 person found this helpful

Attachments

    Outcomes