Malwarebytes for Mac and macOS High Sierra

Document created by parche Employee on Aug 2, 2017Last modified by asmith on Sep 25, 2017
Version 10Show Document
  • View in full screen mode

Starting with v3.0.3, Malwarebytes for Mac is compatible with macOS High Sierra 10.13.  If you are running macOS High Sierra, we recommend you update to Malwarebytes for Mac v3.0.3.  To download the latest version, click here.

 

To see the current system requirements, refer to Malwarebytes for Mac Tech Specs.

 

Additional information

Attachments

    Outcomes